[Oracle Java] 오라클 자바 JRE 신규취약점 발견!! (2012-09-27)

반응형


자바취약점 0-Day가 나오고 보안패치가 나온지 얼마나 되었다고, 또 자바 취약점이 발견되었다.

이번 취약점은 외국 보안전문 회사인 시큐리티 익스플로레이션(Security Exploration)에서 발견되었으며
윈도우 7 32Bit 테스트를 하였으며 자바 SE 5,6,7 버전에서 "자바 시큐리티 샌드박스"를 우회할 수 있는 취약점이 있다고 한다.

현재 자바를 설치 한 PC는 약 10억만명(1,000,000,000)이라고 오라클에서 제공하는 설치 통계에 나와 있다고 한다.
그 만큼 자바를 많이 사용하고 설치 되어 있는데, 이런 취약점을 발견 시 오라클에서는 빠르게 조치를 해야 할 것이다.

아직 정확한 취약점 정보나 POC 코드는 나오지 않았지만, 암튼 조심해야 한다;;

현재까지 확인 된 사항이다.

■ 취약한 자바 버전

- Java SE 5 Update 22 (build 1.5.0_22-b03)
- Java SE 6 Update 35 (build 1.6.0_35-b10)
- Java SE 7 Update 7  (build 1.7.0_07-b10)

■  테스트 환경(Win7 32Bit)에서 취약점을 이용할 수 있는 브라우저
- Firefox 15.0.1
- Google Chrome 21.0.1180.89
- Internet Explorer 9.0.8112.16421 (update 9.0.10)
- Opera 12.02 (build 1578)
- Safari 5.1.7 (7534.57.2)


현재 해당 취약점은 아직 악성코드로 이용되는 제로데이(0-Day)는 아니나, 언제 발생될 지 모르는 상황이니
사용자는 인터넷 사용시 유의 해야 하며, 
아래의 수동적인 방법으로 취약점을 우회 할 수는 있으니, 참고하시기 바람!!

<브라우저 별 자바 애플릿 보안기능 설정 방법>
 
- MS Internet Explorer
[도구]-[인터넷 옵션]-[보안]-[사용자 지정 수준]-[스크립팅]-[Java 애플릿 스크립팅]을 "사용 안 함"으로 선택
 
- Mozilla Firefox
[도구]-[부가 기능]-[플러그인]-[Java(TM) Platform SE]을 "사용 안 함" 으로 선택
 
- Google Chrome
[도구]-[설정]-[고급]-[컨텐츠설정]-[플러그인]에서 "개별 플러그인 사용 중지" 선택 후 Java 사용 중지



댓글(4)

Designed by JB FACTORY